iis - NsisIIS-插件要求

原文 标签 iis nsis

NsisIIS - plugin requirements

Does anyone know the requirements of the NsisIIS plugin?

I am getting this error:

code: Could not load: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\nsb2.tmp\NsisIIS.dll

This is on a Window Server 2003, which has IIS installed and running. I am logged onto the server as an adminsitrator.

Thank you.

Answer

The plugin seems to require MSVCR100.DLL and MSVCP100.DLL so it probably needs the Visual C++ 2010 Redistributable Package (x86). You should ask the author if he could create a statically linked version or use a older version of VC that links to MSVCRT.DLL (Or compile yourself, the source code is on sourceforge)

翻译

有谁知道NsisIIS插件的要求?

我收到此错误:

code: Could not load: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\nsb2.tmp\NsisIIS.dll

这是在已安装并正在运行IIS的Window Server 2003上。我以管理员身份登录到服务器。

谢谢。
最佳答案
该插件似乎需要MSVCR100.DLL和MSVCP100.DLL,因此它可能需要Visual C++ 2010 Redistributable Package (x86)。您应该询问author他是否可以创建静态链接版本或使用链接到MSVCRT.DLL的旧版VC(或者自己编译,源代码在sourceforge上)
相关推荐

iis - 使用一个Logging Application Block日志文件进行多个进程

.net - 为什么.NET突然尝试在ASP.NET应用程序中序列化我的对象?

silverlight - Silverlight托管查询[关闭]

apache - 有没有一种方法可以美化网络服务器生成的目录列表的样式?

asp.net-mvc-3 - 通过SharePoint 2010上的虚拟文件夹映射的ASP.NET 4.0应用

php - $ _SESSION的问题

php - cakephp缓存文件夹在iis上不可写

asp.net - 如何将网站部署到生产环境中而对用户的影响最小

.net - 3.5应用程序池下的ASP.NET 4.0应用程序

iis - 如何确定服务器场中的哪个Web服务器为请求提供服务?