android - Android 2.2到1.6?

原文 标签 android android-version

android 2.2 to 1.6?

I have been developing an android app. I had chosen 2.2 as the version. I have not used any advanced features that are specific to 2.2 or above. I want my app to work with 1.6 and above. What should I do?

Thanks.

Answer

Complement preview answers.

android make upward compatible your code automatically as much as possible (not always).
But lowering the api level of an app. Can be a task from simple to nightmare to execute, all depends if your code use a lot of specific 2.2 ... That's means changing API level or android.jar in your project may be far to be enough.

good luck

翻译

我一直在开发一个android应用程序。我选择了2.2作为版本。我没有使用任何特定于2.2或更高版本的高级功能。我希望我的应用程序可以在1.6及更高版本上使用。我该怎么办?

谢谢。
最佳答案
补充预览答案。

android会尽可能自动(并非总是如此)自动向上兼容您的代码。
但是降低应用程序的api级别。从简单到噩梦的执行都是一个任务,这完全取决于您的代码是否使用了很多特定的2.2 ...
这意味着在项目中更改API级别或android.jar可能已足够。

祝好运
相关推荐

android - 位图大小超过VM预算Android上的错误

android - 无法在通知中添加其他内容

android - 在Android中缩放图像

java - 无法在Android上使用正则表达式实现部分匹配

android - android xml标签字符串组合

java - 在Android上下载-FileNotFoundException,但文件存在

android - 视图的边框纹理

android - 如何从通用对话框类中获取数据

android - Color.rgb在Android中做什么?

android - 在Android中创建目录时遇到问题